View Issue Details

IDProjectCategoryView StatusLast Update
0001520SOGoBackend Calendarpublic2011-12-05 15:57
Reportercwright Assigned Towsourdeau 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.3.10 
Fixed in Version1.3.11 
Summary0001520: Setting categories in Lightning causes exception
Description

After upgrading to 1.3.10 I see exceptions in SOGo that appear to be related to setting task and event categories.

1) Setting categories for events and tasks in Lightning causes exceptions.

Example:

localhost.localdomain - - [01/Dec/2011:11:06:48 GMT] "REPORT /SOGo/dav/cwright/Calendar/sogo_37E-4AF8AA80-17-5DC589F0/ HTTP/1.1" 207 125/245 0.025 - - 320K
Dec 01 11:06:48 sogod [12441]: <<0x021B6DC8[SOGoTaskObject]:fb06f379-286f-488c-8550-04debc736fb0.ics>>D etag '"gcs00000000"' matches: "gcs00000000"
EXCEPTION: <NSException: 0x2125d48> NAME:NSInvalidArgumentException REASON:GSMutableArray(instance) does not recognize stringValueForPostgreSQLType:attribute: INFO:(null)
Dec 01 11:06:48 sogod [934]: <0x0x1d072a8[WOWatchDogChild]> child 12441 exited
Dec 01 11:06:48 sogod [934]: <0x0x1d072a8[WOWatchDogChild]> (terminated due to signal 6)

2) Setting categories for events and tasks in the Web interface does not cause exceptions, but the category selections are not saved.

Additional Information

Tested with Lightning 1.06 and 1.07 on 64-bit Linux and Windows.

Noticed the same behavior (of categories not being saved) on the demo site.

TagsNo tags attached.

Activities

cwright

cwright

2011-12-01 13:49

reporter   ~0003094

Noticed my typo, add-on versions were 3.106 and 3.107. Using Thunderbird 3.1.15 and 3.1.16. Thank you!

chrroessner

chrroessner

2011-12-05 15:37

reporter   ~0003113

I can confirm this problem. 1.3.10 on Ubuntu 10.04.3/64bit

grep "NSInvalidArgumentException" sogo.log
EXCEPTION: <NSException: 0x25891c0> NAME:NSInvalidArgumentException REASON:GSMutableArray(instance) does not recognize stringValueForPostgreSQLType:attribute: INFO:(nil)
EXCEPTION: <NSException: 0x267a630> NAME:NSInvalidArgumentException REASON:GSMutableArray(instance) does not recognize stringValueForPostgreSQLType:attribute: INFO:(nil)
EXCEPTION: <NSException: 0x2665e60> NAME:NSInvalidArgumentException REASON:GSMutableArray(instance) does not recognize stringValueForPostgreSQLType:attribute: INFO:(nil)

The problem is bad, as events and tasks disappear in lightning. By the way: tb-8 with stable lightning here.

Christian

cwright

cwright

2011-12-05 15:48

reporter   ~0003114

Christian, thank you for noting that. You are right, events disappear (they never appear to get written to the server). We see the affected calendar go read-only for the user and the user gets an error dialog repeatedly that they cannot stop from reappearing until the cache.sqlite file is deleted in their Thunderbird profile.

wsourdeau

wsourdeau

2011-12-05 15:57

viewer   ~0003115

This has been fixed. Please try the nightly builds.

Issue History

Date Modified Username Field Change
2011-12-01 13:44 cwright New Issue
2011-12-01 13:49 cwright Note Added: 0003094
2011-12-05 15:37 chrroessner Note Added: 0003113
2011-12-05 15:48 cwright Note Added: 0003114
2011-12-05 15:57 wsourdeau Note Added: 0003115
2011-12-05 15:57 wsourdeau Status new => resolved
2011-12-05 15:57 wsourdeau Fixed in Version => 1.3.11
2011-12-05 15:57 wsourdeau Resolution open => fixed
2011-12-05 15:57 wsourdeau Assigned To => wsourdeau