View Issue Details

IDProjectCategoryView StatusLast Update
0001497SOGoBackend Generalpublic2011-11-16 10:06
ReporterwsourdeauAssigned Towsourdeau 
PrioritynormalSeveritymajorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version1.3.9 
Target Version1.3.10Fixed in Version1.3.10 
Summary0001497: escaping of ; and ,
Description

Various versions of SOGo escape either one of them, or both, but sometimes in the wrong context.
For example, certain versions used to escape commas and semicolon, resulting in proper SUMMARY fields such as "SUMMARY:Hi\, this contains a comma" but also wrong RRULE fields such as "RRULE:BYDAY=MO\,TU\,SU;FREQ=WEEKLY".

This needs to be fixed once and for all for all use cases.

TagsNo tags attached.

Relationships

duplicate of 0000892 resolvedwsourdeau fix vcard parsing and output with unit tests 

Activities

wsourdeau

wsourdeau

2011-11-14 13:00

viewer   ~0002999

Properly fixed in dac752317ac0c81975ef28320e87acabbe394823

Issue History

Date Modified Username Field Change
2011-11-14 12:59 wsourdeau New Issue
2011-11-14 12:59 wsourdeau Fixed in Version => 1.3.10
2011-11-14 12:59 wsourdeau Target Version => 1.3.10
2011-11-14 13:00 wsourdeau Note Added: 0002999
2011-11-14 13:00 wsourdeau Status new => resolved
2011-11-14 13:00 wsourdeau Resolution open => fixed
2011-11-14 13:00 wsourdeau Assigned To => wsourdeau
2011-11-14 13:06 wsourdeau Description Updated
2011-11-16 10:06 wsourdeau Relationship added duplicate of 0000892