View Issue Details

IDProjectCategoryView StatusLast Update
0000149SOGoWeb Calendarpublic2009-09-28 11:21
Reporterwimmer Assigned Toludovic  
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Product Versionnightly v2 
Fixed in Version1.1.0 
Summary0000149: WebCalendar doesn't subscribe webcalendar without events, same for import
Description

1) SOGo cannot subscribe empty webcalendar (I mean webcalendar nonincluding
any event)
2) SOGo cannot import empty ICS calendar file (calendar without events)

There is no error in the log, SOGo writes an error message.

We are using school timetable ICS for both webcalendar and imports and it is correct when ICS do not include any event.

Thanks.

TagsNo tags attached.

Activities

ludovic

ludovic

2009-09-24 07:17

administrator   ~0000128

What's the exact output of your file when there's no event in it?

Is it an empty file or is it a file with no BEGIN:VEVENT in it but you still have the BEGIN:VCALENDAR/END:VCALENDAR ?

We have some sanity checks to avoid empty files but it might be adjusted.

2009-09-24 07:30

 

empty.ics (460 bytes)   
BEGIN:VCALENDAR
VERSION:2.0
CALSCALE:GREGORIAN
METHOD:PUBLISH
X-WR-TIMEZONE:Europe/Prague
BEGIN:VTIMEZONE
TZID:Europe/Prague
X-LIC-LOCATION:Europe/Prague
BEGIN:DAYLIGHT
TZOFFSETFROM:+0100
TZOFFSETTO:+0200
TZNAME:CEST
DTSTART:19700329T020000
RRULE:FREQ=YEARLY;BYMONTH=3;BYDAY=-1SU
END:DAYLIGHT
BEGIN:STANDARD
TZOFFSETFROM:+0200
TZOFFSETTO:+0100
TZNAME:CET
DTSTART:19701025T030000
RRULE:FREQ=YEARLY;BYMONTH=10;BYDAY=-1SU
END:STANDARD
END:VTIMEZONE
END:VCALENDAR
empty.ics (460 bytes)   
wimmer

wimmer

2009-09-24 07:36

reporter   ~0000129

I uploaded that file.
File is not empty, it includes ICS structure.

But you can try to create new (empty) calendar in SOGo, then to export it into ics file and then import same file into SOGo calendar. It doesn't work too.
ICS file has following content in this case:

BEGIN:VCALENDAR
VERSION:2.0
END:VCALENDAR

Thanks

ludovic

ludovic

2009-09-27 21:15

administrator   ~0000133

Fixed by http://mtn.inverse.ca/revision/diff/b60d547047a2529bf2428a9d602340aa1c4f7f9b/with/1aaea249ad1360b144fa338a55f11cad2cf930d0

wimmer

wimmer

2009-09-28 07:17

reporter   ~0000134

Sorry for reopening...

Yes,
point 1) [subscribtion of empty webcalendar] works great now. Thank you.

point 2) [import of ICS calendar file without events) does not work yet.
SOGo displays error message when:

  • I'm importing ICS file without events (example same file as I uploaded here)
  • I create new SOGo calendar, do "Export" to ICS file it and then I'm trying to import it.

Thanks

ludovic

ludovic

2009-09-28 07:44

administrator   ~0000136

I've just tried and it works.

Try to subscribe to http://inverse.ca/~lmarcotte/veryempty

wimmer

wimmer

2009-09-28 10:10

reporter   ~0000137

Ludovic,
it looks we are talking about different thing.
As I wrote - subscribtion of empty remote webcalendars works nice now.

I found incorrect message by "import" of 'empty' calendar from ics file.
Here is step-by-step example:

  • logon as sogo1 to http://sogo-demo.inverse.ca/
  • create new empty calendar "w1"
  • export this empty calendar into w1.ics file
  • create new empty calendar "w2"
  • try to import w1.ics into "w2" => SOGo display:
    "Import
    An error occured while importing calendar."

I would expect message:
"Import
Imported events: 0"

because it is correct to import 0 events - it is no error.

ludovic

ludovic

2009-09-28 10:16

administrator   ~0000138

Ahh..

in SchedulerUI.js, you have:

function uploadCompleted (response) {
data = response.evalJSON (true);

var div = $("uploadResults");
$("uploadOK").onclick = hideImportResults;
if (data.imported <= 0)

try to replace:

if (data.imported <= 0)

with:

if (data.imported < 0)
wimmer

wimmer

2009-09-28 10:32

reporter   ~0000139

Yes ;-)

now import works like I expected.
Please update mtn and close this track.

Thank you,
Milos

ludovic

ludovic

2009-09-28 11:21

administrator   ~0000140

Closed with http://mtn.inverse.ca/revision/diff/1aaea249ad1360b144fa338a55f11cad2cf930d0/with/5052783f79bc86c62042f5d4a556a3573c4a3876

Issue History

Date Modified Username Field Change
2009-09-24 03:45 wimmer New Issue
2009-09-24 07:17 ludovic Note Added: 0000128
2009-09-24 07:30 wimmer File Added: empty.ics
2009-09-24 07:36 wimmer Note Added: 0000129
2009-09-27 21:15 ludovic Note Added: 0000133
2009-09-27 21:15 ludovic Status new => resolved
2009-09-27 21:15 ludovic Fixed in Version => 1.1.0
2009-09-27 21:15 ludovic Resolution open => fixed
2009-09-27 21:15 ludovic Assigned To => ludovic
2009-09-28 07:17 wimmer Note Added: 0000134
2009-09-28 07:17 wimmer Status resolved => feedback
2009-09-28 07:17 wimmer Resolution fixed => reopened
2009-09-28 07:44 ludovic Note Added: 0000136
2009-09-28 10:10 wimmer Note Added: 0000137
2009-09-28 10:16 ludovic Note Added: 0000138
2009-09-28 10:32 wimmer Note Added: 0000139
2009-09-28 11:21 ludovic Note Added: 0000140
2009-09-28 11:21 ludovic Status feedback => resolved
2009-09-28 11:21 ludovic Resolution reopened => fixed