View Issue Details

IDProjectCategoryView StatusLast Update
0001471SOGoBackend Calendarpublic2012-02-03 11:01
Reporterdme Assigned Tofrancis  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.3.8 
Target Version1.3.12Fixed in Version1.3.12 
Summary0001471: Resources auto-accept invitations even with conflicts with recurring events
Description

Lightning issues no warning when we try to book an event at same time of a recurring event, and happily accepts the invitation if the user bypasses this warning and clicks on "save and close".

Expected behavior would be that the resource then rejects the invitation.

Additional Information

Versions:

Lightning: 1.0b2+105i
Sogo connector: 3.105
Sogo integrator: 3.105
Sogo: 1.3.8b

SOGoUserSources:
<key>MultipleBookingsFieldName</key>
<string>Multiplebookings</string>

LDAP:
Multiplebookings = 1

TagsNo tags attached.

Activities

joolsr

joolsr

2011-10-21 04:34

reporter   ~0002937

I have the same issue. From discussions on the mailing list before I believe the issue is within Lightning rather than Sogo, ie that Lightning doesn't know what to do in the case of colliding events, thus producing an error rather than something more meaningful.

In the web interface that sogo has far more control over, colliding events are handled much much better...

ludovic

ludovic

2011-11-17 15:58

administrator   ~0003038

This is a bug in SOGo/SOPE's recurrence rule calculator it seems. We'll have to investigate some more but I can reproduce the issue.

iczeh

iczeh

2011-11-21 09:45

reporter   ~0003046

Last edited: 2011-11-21 09:47

I have the same issue without using Lightning (i.e. I can reproduce it on the SOGo web interface).

Multiple booking limit works fine with non-recurring events, the resource cannot be overbooked once the preset limit has been reached and the resource was booked previously by non-recurring event.

The resource can be overbooked by a recurring event even if it was booked already by a non-recurring event or it can be overbooked by a non-recurring event if it was booked by a recurring event.

Summary: if a recurring event is part of the story, then it fails.

Version 1.3.9

francis

francis

2012-02-03 11:01

administrator   ~0003356

Fixed in revision dd31018a0c1b88afe90d371ba63164a518d02876.

Issue History

Date Modified Username Field Change
2011-10-20 12:10 dme New Issue
2011-10-21 04:34 joolsr Note Added: 0002937
2011-10-30 20:32 ludovic Target Version => 1.3.10
2011-11-17 15:58 ludovic Note Added: 0003038
2011-11-18 13:32 ludovic Target Version 1.3.10 => 1.3.11
2011-11-21 09:45 iczeh Note Added: 0003046
2011-11-21 09:47 iczeh Note Edited: 0003046
2011-12-12 12:35 francis Target Version 1.3.11 => 1.3.12
2012-02-03 11:01 francis Note Added: 0003356
2012-02-03 11:01 francis Status new => resolved
2012-02-03 11:01 francis Fixed in Version => 1.3.12
2012-02-03 11:01 francis Resolution open => fixed
2012-02-03 11:01 francis Assigned To => francis