View Issue Details

IDProjectCategoryView StatusLast Update
0001457SOGoApple iPhone OSpublic2011-10-17 14:43
Reportergb Assigned Toludovic  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.3.6 
Target Version1.3.9Fixed in Version1.3.9 
Summary0001457: iPhone 5 GM missing calendars
Description

Some calendars are missing in the iCal app of the new iPhone 5 GM version. This is the almost final version of the new Apple iOS firmware. On our local 1.3.6 production server, the personal calendar (the default one of a user account) does not display, at least tested with my user account.

Same happends on our local testing server running Version 2.0.0 (201110041128) and also on your demo server (sogo-demo.inverse.ca) set up with the sogo1 demo account. Things are even more strange with your demo server as the iPhone only show 3 calendars for this account (iCal, Test_01 and Test_02) whereas the web client shows 12 calendars at this hour.

All setup are done on the iPhone using a CalDAV server. We can provide traces on the server side if you need them or do whatever tests you'd like us to run.

TagsNo tags attached.

Activities

ludovic

ludovic

2011-10-07 11:41

administrator   ~0002876

We'll update our test device and report.

mmag

mmag

2011-10-07 13:12

reporter   ~0002877

Same behaviour with iOS 5 GM and Server 1.38b running. Personal calender is missing on iPhone, other calendars fully working.

mra

mra

2011-10-13 03:58

reporter   ~0002888

Last edited: 2011-10-13 03:58

Same with released iOS 5 (Server: Debian Lenny, SOGo 1.3.8b)

pflaeging

pflaeging

2011-10-13 06:02

reporter   ~0002890

I've got the same problem. Here's what my server says if I make a "reload" of the calendar tab!

localhost.localdomain - - [13/Oct/2011:11:59:38 GMT] "PROPFIND /SOGo/dav/peter/ HTTP/1.1" 401 0/823 0.003 - - 0
2011-10-13 11:59:38.725 sogod[27955] -[WEClientCapabilities initWithRequest:]: Unknown WebClient: user-agent='iOS/5.0 (9A334) dataaccessd/1.0'
localhost.localdomain - - [13/Oct/2011:11:59:38 GMT] "PROPFIND /SOGo/dav/peter/ HTTP/1.1" 207 595/823 0.006 1822 67% 0
2011-10-13 11:59:38.778 sogod[27955] -[WEClientCapabilities initWithRequest:]: Unknown WebClient: user-agent='iOS/5.0 (9A334) dataaccessd/1.0'
localhost.localdomain - - [13/Oct/2011:11:59:38 GMT] "OPTIONS /SOGo/dav/peter/ HTTP/1.1" 200 0/0 0.002 - - 0
2011-10-13 11:59:38.824 sogod[27955] -[WEClientCapabilities initWithRequest:]: Unknown WebClient: user-agent='iOS/5.0 (9A334) dataaccessd/1.0'
localhost.localdomain - - [13/Oct/2011:11:59:38 GMT] "PROPFIND /SOGo/dav/peter/Calendar/ HTTP/1.1" 207 2171/1925 0.044 31976 93% 0

:peter

Marcel

Marcel

2011-10-17 12:49

reporter   ~0002918

Last edited: 2011-10-17 13:19

The problem is that iOS 5 devices are no longer recognized by the code as iPhones, resulting in the iDevice choking on the schedule-outbox resourcetype associated with the main calendar.

The two attached patches (SOGo.diff and SOPE.diff) fix this. I have tested this on an iPhone 4 with iOS 5 and the main calendar is finally visible again.

2011-10-17 12:49

 

SOGo.diff (643 bytes)   
#
# old_revision [ae854e507775b3fdae95a26349d47bfe9fc5272e]
#
# patch "SoObjects/SOGo/WORequest+SOGo.m"
#  from [c9949da0a530fd43727bbe60f16fa661991cd414]
#    to [345f2b7e073383096d588d62e43835d6c4331fb7]
#
============================================================
--- SoObjects/SOGo/WORequest+SOGo.m	c9949da0a530fd43727bbe60f16fa661991cd414
+++ SoObjects/SOGo/WORequest+SOGo.m	345f2b7e073383096d588d62e43835d6c4331fb7
@@ -125,7 +125,8 @@
 
 - (BOOL) isIPhone
 {
-  return [self isAppleDAVWithSubstring: @"iPhone/"];
+  return [self isAppleDAVWithSubstring: @"iPhone/"]
+	 || [self isAppleDAVWithSubstring: @"iOS/"];
 }
 
 - (BOOL) isICal
SOGo.diff (643 bytes)   

2011-10-17 12:50

 

SOPE.diff (919 bytes)   
#
# old_revision [b0432fdb98b2862ae32a89856985a7f182a91efc]
#
# patch "sope-appserver/NGObjWeb/WEClientCapabilities.m"
#  from [9e8bbfe022de85c97e5791447832899bf491700e]
#    to [92d1b4efabd65f50268c9dfbcb705c87ae300683]
#
============================================================
--- sope-appserver/NGObjWeb/WEClientCapabilities.m	9e8bbfe022de85c97e5791447832899bf491700e
+++ sope-appserver/NGObjWeb/WEClientCapabilities.m	92d1b4efabd65f50268c9dfbcb705c87ae300683
@@ -337,6 +337,10 @@
     /* some iCal 1.x DAV Access Framework, report as Apple DAV access */
     self->browser = WEUA_AppleDAVAccess;
   }
+  else if (strstr(ua, "dataaccessd/")) {
+    /* iOS 5.x (iPhone/iPad) DAV Access Framework, report as Apple DAV access */
+    self->browser = WEUA_AppleDAVAccess;
+  }
   else if (strstr(ua, "Microsoft Data Access Internet Publishing Provider")) {
     /* WebFolder */
     self->browser = WEUA_WebFolder;
SOPE.diff (919 bytes)   
ludovic

ludovic

2011-10-17 14:43

administrator   ~0002920

Fixed with:

http://mtn.inverse.ca/revision/diff/ae854e507775b3fdae95a26349d47bfe9fc5272e/with/6ad817abd0c038e9c0fd0d18eb1cdcbca563a507

and:

http://mtn.inverse.ca/revision/diff/b0432fdb98b2862ae32a89856985a7f182a91efc/with/db3e36b4a57015b6741490de2d7a027515484d89

Issue History

Date Modified Username Field Change
2011-10-06 13:36 gb New Issue
2011-10-07 11:41 ludovic Note Added: 0002876
2011-10-07 11:41 ludovic Status new => assigned
2011-10-07 11:41 ludovic Assigned To => ludovic
2011-10-07 13:12 mmag Note Added: 0002877
2011-10-13 03:58 mra Note Added: 0002888
2011-10-13 03:58 mra Note Edited: 0002888
2011-10-13 06:02 pflaeging Note Added: 0002890
2011-10-13 15:01 ludovic Target Version => 1.3.9
2011-10-17 12:49 Marcel Note Added: 0002918
2011-10-17 12:49 Marcel File Added: SOGo.diff
2011-10-17 12:50 Marcel File Added: SOPE.diff
2011-10-17 13:19 Marcel Note Edited: 0002918
2011-10-17 14:43 ludovic Note Added: 0002920
2011-10-17 14:43 ludovic Status assigned => resolved
2011-10-17 14:43 ludovic Fixed in Version => 1.3.9
2011-10-17 14:43 ludovic Resolution open => fixed