View Issue Details

IDProjectCategoryView StatusLast Update
0001447SOGoWeb Preferencespublic2016-06-15 16:09
Reporterfe Assigned Tofrancis  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.3.8a 
Fixed in Version3.1.3 
Summary0001447: Cannot specify a text for the vacation reply subject
Description

There is no way to specify the subject of the vacation message,
e.g.

Out of office
Abwesenheitsnachricht
Autoreply
Autom. Antwort:

Furthermore, should the subject of the incoming message be written
after this subject?

TagsNo tags attached.

Relationships

duplicate of 0000685 resolvedfrancis Vacation / autoresponder : Subject 

Activities

ludovic

ludovic

2011-12-30 11:31

administrator   ~0003227

See: http://tools.ietf.org/html/draft-ietf-sieve-vacation-07#section-4.3 for details on this.

Gunnar Weissmann

Gunnar Weissmann

2014-07-30 12:39

reporter   ~0007368

SOGo doesn't set a ":subject" value, so sieve uses the "auto" default value.

We think it would be useful if there would be the possibility to set a subject in the sogo webinterface.

Is this thinkable?

Thank you.

thierry

thierry

2015-03-02 05:02

reporter   ~0008242

Better, it would be nice to have

  • possibility to set a subject in the sogo interface by users
  • possibility to force a prefix of the subject by admins (i.e. [AUTOREPLY] or something like that)

Is this possible?

Thanks,
Regards,

Related Changesets

sogo: master d8fc4021

2016-06-15 16:02:12

francis

Details Diff
Specify a custom vacation subject

User can now specify a custom vacation subject. For Sieve servers
implementing the variables extension, one can write ${subject} to insert
the original subject in the auto reply.

SOGoDefaultVacationSubject is a new domain defaults parameter used when
the user doesn't specify a custom subject.

Fixes 0000685, 0001447
Affected Issues
0000685, 0001447
mod - Documentation/SOGoInstallationGuide.asciidoc Diff File
mod - NEWS Diff File
mod - SoObjects/SOGo/SOGoDomainDefaults.h Diff File
mod - SoObjects/SOGo/SOGoDomainDefaults.m Diff File
mod - SoObjects/SOGo/SOGoSieveManager.m Diff File
mod - UI/PreferencesUI/English.lproj/Localizable.strings Diff File
mod - UI/PreferencesUI/UIxJSONPreferences.m Diff File
mod - UI/Templates/PreferencesUI/UIxPreferences.wox Diff File
mod - UI/WebServerResources/js/Preferences/PreferencesController.js Diff File
mod - UI/WebServerResources/scss/components/input/input.scss Diff File

Issue History

Date Modified Username Field Change
2011-09-15 10:04 fe New Issue
2011-12-30 11:31 ludovic Note Added: 0003227
2014-07-30 12:39 Gunnar Weissmann Note Added: 0007368
2015-03-02 05:02 thierry Note Added: 0008242
2016-05-19 08:47 francis Relationship added duplicate of 0000685
2016-06-15 16:06 francis Changeset attached => sogo master d8fc4021
2016-06-15 16:06 francis Assigned To => francis
2016-06-15 16:06 francis Resolution open => fixed
2016-06-15 16:09 francis Status new => resolved
2016-06-15 16:09 francis Fixed in Version => 3.1.3