View Issue Details

IDProjectCategoryView StatusLast Update
0001426SOGoWeb Mailpublic2011-10-14 15:15
ReporterChristian Mack Assigned Tofrancis  
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
PlatformLinux 
Product Version1.3.8a 
Target Version1.3.9Fixed in Version1.3.9 
Summary0001426: Somtimes wrong email list is displayed
Description

When going from one email folder to another, sometimes you get the wrong emails listed.
Instead of the emails of the fresh opend folder you get the emails of the previously visited one.

When trying to open one of these you naturally get an error, because the requested email doesn't exist in this folder.

This seems to be a race condition.
Because when you get it, there is always an automatic reload of the list in background at the same time. Or you have to switch folders very fast.

I assume the automatic reload answer is handed over to the opening folder query.

Steps To Reproduce

Switch fast between folders and don't wait till the just opened one is displayed before switching to the next.
Then sometimes you will see the content listed from the old folder as content for the next folder.

TagsNo tags attached.

Activities

francis

francis

2011-10-14 15:15

administrator   ~0002912

Fixed in revision da1d45b607b5db68530b2ee303a1bcc9b6ef3057.

Issue History

Date Modified Username Field Change
2011-08-22 06:21 Christian Mack New Issue
2011-08-23 10:45 francis Target Version => 1.3.9
2011-10-14 15:15 francis Note Added: 0002912
2011-10-14 15:15 francis Status new => resolved
2011-10-14 15:15 francis Fixed in Version => 1.3.9
2011-10-14 15:15 francis Resolution open => fixed
2011-10-14 15:15 francis Assigned To => francis