View Issue Details

IDProjectCategoryView StatusLast Update
0001424SOGoBackend Address Bookpublic2011-11-21 09:28
Reporterjohnsonua Assigned Toludovic  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version1.3.8 
Target Version1.3.10Fixed in Version1.3.10 
Summary0001424: Address Book in OS X 10.7 does not show the personal address book, but the directory
Description

Setting up SOGo as a carddav source in OS X 10.7 results in the entire directory being pulled into address book, not the personal address book.

Looking in the ab-access log you can see that 10.7 sends a different set of PROPFIND requests to Sogo than 10.6 does.

I've attached the initial discovery phase of both systems connecting for the first time from the ab-access.log perhaps theres a bug in the response from SOGo?

TagsNo tags attached.

Activities

2011-08-18 16:25

 

sogo address book bug report.txt (8,348 bytes)   
ab-access.log selection for OS X 10.6 and OS X 10.7 Address book Carddav initial communications with server:

From 10.7 system:

[root@sogo httpd]# grep 128.196.45.230 ab-access.log
128.196.45.230 - - [18/Aug/2011:09:18:39 -0700] "PROPFIND /.well-known/carddav HTTP/1.1" 404 43 "-" "AddressBook/6.0 (1043) CardDAVPlugin/182 CFNetwork/520.0.13 Mac_OS_X/10.7.1 (11B26)"
128.196.45.230 - - [18/Aug/2011:09:18:39 -0700] "PROPFIND / HTTP/1.1" 401 - "-" "AddressBook/6.0 (1043) CardDAVPlugin/182 CFNetwork/520.0.13 Mac_OS_X/10.7.1 (11B26)"
128.196.45.230 - - [18/Aug/2011:09:18:39 -0700] "PROPFIND / HTTP/1.1" 207 478 "-" "AddressBook/6.0 (1043) CardDAVPlugin/182 CFNetwork/520.0.13 Mac_OS_X/10.7.1 (11B26)"
128.196.45.230 - - [18/Aug/2011:09:18:39 -0700] "OPTIONS / HTTP/1.1" 200 - "-" "AddressBook/6.0 (1043) CardDAVPlugin/182 CFNetwork/520.0.13 Mac_OS_X/10.7.1 (11B26)"
128.196.45.230 - - [18/Aug/2011:09:18:39 -0700] "PROPFIND /SOGo/dav/johnson/ HTTP/1.1" 207 478 "-" "AddressBook/6.0 (1043) CardDAVPlugin/182 CFNetwork/520.0.13 Mac_OS_X/10.7.1 (11B26)"
128.196.45.230 - - [18/Aug/2011:09:18:39 -0700] "PROPFIND /SOGo/dav/johnson/Contacts/ HTTP/1.1" 207 788 "-" "AddressBook/6.0 (1043) CardDAVPlugin/182 CFNetwork/520.0.13 Mac_OS_X/10.7.1 (11B26)"
128.196.45.230 - - [18/Aug/2011:09:18:40 -0700] "PROPFIND /SOGo/dav/johnson/ HTTP/1.1" 207 478 "-" "AddressBook/6.0 (1043) CardDAVPlugin/182 CFNetwork/520.0.13 Mac_OS_X/10.7.1 (11B26)"
128.196.45.230 - - [18/Aug/2011:09:18:40 -0700] "PROPFIND /SOGo/dav/johnson/Contacts/ HTTP/1.1" 207 788 "-" "AddressBook/6.0 (1043) CardDAVPlugin/182 CFNetwork/520.0.13 Mac_OS_X/10.7.1 (11B26)"
128.196.45.230 - - [18/Aug/2011:09:18:40 -0700] "PROPFIND /SOGo/dav/johnson/Contacts/directory/ HTTP/1.1" 207 403 "-" "AddressBook/6.0 (1043) CardDAVPlugin/182 CFNetwork/520.0.13 Mac_OS_X/10.7.1 (11B26)"
128.196.45.230 - - [18/Aug/2011:09:18:40 -0700] "PROPFIND /SOGo/dav/johnson/Contacts/directory/ HTTP/1.1" 207 15818 "-" "AddressBook/6.0 (1043) CardDAVPlugin/182 CFNetwork/520.0.13 Mac_OS_X/10.7.1 (11B26)"
128.196.45.230 - - [18/Aug/2011:09:18:49 -0700] "GET /SOGo/dav/johnson/Contacts/directory/petersen HTTP/1.1" 200 213 "-" "AddressBook/6.0 (1043) CardDAVPlugin/182 CFNetwork/520.0.13 Mac_OS_X/10.7.1 (11B26)"

Remaining entries are adding the directory entries to the address book....

From 10.6 system: (this system was done first and the address book was loaded up from here, hence the PUT commands...)

[root@sogo httpd]# grep 128.196.45.237 ab-access.log
128.196.45.237 - - [18/Aug/2011:09:04:03 -0700] "PROPFIND / HTTP/1.1" 401 - "-" "Address%20Book/883 CFNetwork/454.12.4 Darwin/10.8.0 (i386) (iMac11%2C3)"
128.196.45.237 - - [18/Aug/2011:09:04:03 -0700] "PROPFIND / HTTP/1.1" 207 318 "-" "Address%20Book/883 CFNetwork/454.12.4 Darwin/10.8.0 (i386) (iMac11%2C3)"
128.196.45.237 - - [18/Aug/2011:09:04:03 -0700] "REPORT /SOGo/dav/johnson/ HTTP/1.1" 401 - "-" "Address%20Book/883 CFNetwork/454.12.4 Darwin/10.8.0 (i386) (iMac11%2C3)"
128.196.45.237 - - [18/Aug/2011:09:04:03 -0700] "REPORT /SOGo/dav/johnson/ HTTP/1.1" 501 201 "-" "Address%20Book/883 CFNetwork/454.12.4 Darwin/10.8.0 (i386) (iMac11%2C3)"
128.196.45.237 - - [18/Aug/2011:09:04:03 -0700] "PROPFIND /SOGo/dav/johnson/ HTTP/1.1" 401 - "-" "Address%20Book/883 CFNetwork/454.12.4 Darwin/10.8.0 (i386) (iMac11%2C3)"
128.196.45.237 - - [18/Aug/2011:09:04:03 -0700] "PROPFIND /SOGo/dav/johnson/ HTTP/1.1" 207 261 "-" "Address%20Book/883 CFNetwork/454.12.4 Darwin/10.8.0 (i386) (iMac11%2C3)"
128.196.45.237 - - [18/Aug/2011:09:04:03 -0700] "PROPFIND /directory/ HTTP/1.1" 404 27 "-" "Address%20Book/883 CFNetwork/454.12.4 Darwin/10.8.0 (i386) (iMac11%2C3)"
128.196.45.237 - - [18/Aug/2011:09:04:04 -0700] "PROPFIND /directory/ HTTP/1.1" 404 27 "-" "Address%20Book/883 CFNetwork/454.12.4 Darwin/10.8.0 (i386) (iMac11%2C3)"
128.196.45.237 - - [18/Aug/2011:09:04:04 -0700] "PROPFIND /SOGo/dav/johnson/ HTTP/1.1" 401 - "-" "Address%20Book/883 CFNetwork/454.12.4 Darwin/10.8.0 (i386) (iMac11%2C3)"
128.196.45.237 - - [18/Aug/2011:09:04:04 -0700] "PROPFIND /SOGo/dav/johnson/ HTTP/1.1" 207 372 "-" "Address%20Book/883 CFNetwork/454.12.4 Darwin/10.8.0 (i386) (iMac11%2C3)"
128.196.45.237 - - [18/Aug/2011:09:04:04 -0700] "PROPFIND /SOGo/dav/johnson/Contacts/ HTTP/1.1" 401 - "-" "Address%20Book/883 CFNetwork/454.12.4 Darwin/10.8.0 (i386) (iMac11%2C3)"
128.196.45.237 - - [18/Aug/2011:09:04:04 -0700] "PROPFIND /SOGo/dav/johnson/Contacts/ HTTP/1.1" 207 589 "-" "Address%20Book/883 CFNetwork/454.12.4 Darwin/10.8.0 (i386) (iMac11%2C3)"
128.196.45.237 - - [18/Aug/2011:09:04:04 -0700] "PROPFIND /SOGo/dav/johnson/Contacts/personal/ HTTP/1.1" 401 - "-" "Address%20Book/883 CFNetwork/454.12.4 Darwin/10.8.0 (i386) (iMac11%2C3)"
128.196.45.237 - - [18/Aug/2011:09:04:04 -0700] "PROPFIND /SOGo/dav/johnson/Contacts/personal/ HTTP/1.1" 207 306 "-" "Address%20Book/883 CFNetwork/454.12.4 Darwin/10.8.0 (i386) (iMac11%2C3)"
128.196.45.237 - - [18/Aug/2011:09:04:04 -0700] "PROPFIND /SOGo/dav/johnson/Contacts/personal/ HTTP/1.1" 401 - "-" "Address%20Book/883 CFNetwork/454.12.4 Darwin/10.8.0 (i386) (iMac11%2C3)"
128.196.45.237 - - [18/Aug/2011:09:04:04 -0700] "PROPFIND /SOGo/dav/johnson/Contacts/personal/ HTTP/1.1" 207 280 "-" "Address%20Book/883 CFNetwork/454.12.4 Darwin/10.8.0 (i386) (iMac11%2C3)"
128.196.45.237 - - [18/Aug/2011:09:04:34 -0700] "\x16\x03\x01" 401 - "-" "-"
128.196.45.237 - - [18/Aug/2011:09:04:34 -0700] "\x16\x03" 401 - "-" "-"
128.196.45.237 - - [18/Aug/2011:09:14:59 -0700] "PROPFIND / HTTP/1.1" 401 - "-" "Address%20Book/883 CFNetwork/454.12.4 Darwin/10.8.0 (i386) (iMac11%2C3)"
128.196.45.237 - - [18/Aug/2011:09:14:59 -0700] "PROPFIND / HTTP/1.1" 207 318 "-" "Address%20Book/883 CFNetwork/454.12.4 Darwin/10.8.0 (i386) (iMac11%2C3)"
128.196.45.237 - - [18/Aug/2011:09:14:59 -0700] "REPORT /SOGo/dav/johnson/ HTTP/1.1" 401 - "-" "Address%20Book/883 CFNetwork/454.12.4 Darwin/10.8.0 (i386) (iMac11%2C3)"
128.196.45.237 - - [18/Aug/2011:09:14:59 -0700] "REPORT /SOGo/dav/johnson/ HTTP/1.1" 501 201 "-" "Address%20Book/883 CFNetwork/454.12.4 Darwin/10.8.0 (i386) (iMac11%2C3)"
128.196.45.237 - - [18/Aug/2011:09:14:59 -0700] "PROPFIND /SOGo/dav/johnson/ HTTP/1.1" 401 - "-" "Address%20Book/883 CFNetwork/454.12.4 Darwin/10.8.0 (i386) (iMac11%2C3)"
128.196.45.237 - - [18/Aug/2011:09:14:59 -0700] "PROPFIND /SOGo/dav/johnson/ HTTP/1.1" 207 261 "-" "Address%20Book/883 CFNetwork/454.12.4 Darwin/10.8.0 (i386) (iMac11%2C3)"
128.196.45.237 - - [18/Aug/2011:09:14:59 -0700] "PROPFIND /directory/ HTTP/1.1" 404 27 "-" "Address%20Book/883 CFNetwork/454.12.4 Darwin/10.8.0 (i386) (iMac11%2C3)"
128.196.45.237 - - [18/Aug/2011:09:15:00 -0700] "PROPFIND /directory/ HTTP/1.1" 404 27 "-" "Address%20Book/883 CFNetwork/454.12.4 Darwin/10.8.0 (i386) (iMac11%2C3)"
128.196.45.237 - - [18/Aug/2011:09:15:00 -0700] "PROPFIND /SOGo/dav/johnson/Contacts/ HTTP/1.1" 401 - "-" "Address%20Book/883 CFNetwork/454.12.4 Darwin/10.8.0 (i386) (iMac11%2C3)"
128.196.45.237 - - [18/Aug/2011:09:15:00 -0700] "PROPFIND /SOGo/dav/johnson/Contacts/ HTTP/1.1" 207 589 "-" "Address%20Book/883 CFNetwork/454.12.4 Darwin/10.8.0 (i386) (iMac11%2C3)"
128.196.45.237 - - [18/Aug/2011:09:15:00 -0700] "PROPFIND /SOGo/dav/johnson/Contacts/personal/ HTTP/1.1" 401 - "-" "Address%20Book/883 CFNetwork/454.12.4 Darwin/10.8.0 (i386) (iMac11%2C3)"
128.196.45.237 - - [18/Aug/2011:09:15:00 -0700] "PROPFIND /SOGo/dav/johnson/Contacts/personal/ HTTP/1.1" 207 306 "-" "Address%20Book/883 CFNetwork/454.12.4 Darwin/10.8.0 (i386) (iMac11%2C3)"
128.196.45.237 - - [18/Aug/2011:09:15:00 -0700] "PROPFIND /SOGo/dav/johnson/Contacts/personal/ HTTP/1.1" 401 - "-" "Address%20Book/883 CFNetwork/454.12.4 Darwin/10.8.0 (i386) (iMac11%2C3)"
128.196.45.237 - - [18/Aug/2011:09:15:00 -0700] "PROPFIND /SOGo/dav/johnson/Contacts/personal/ HTTP/1.1" 207 280 "-" "Address%20Book/883 CFNetwork/454.12.4 Darwin/10.8.0 (i386) (iMac11%2C3)"
128.196.45.237 - - [18/Aug/2011:09:15:22 -0700] "PUT /SOGo/dav/johnson/Contacts/personal/E0338C1E-A678-4132-B59C-084E22238C13-ABSPlugin.vcf HTTP/1.1" 401 - "-" "Address%20Book/883 CFNetwork/454.12.4 Darwin/10.8.0 (i386) (iMac11%2C3)"

Remaining entries are putting the addresses into the personal address book on the sogo server.

This was confirmed as correct by setting up an iPad, which works correctly, all I got were the personal addresses back from the SOGo server
jtclark

jtclark

2011-11-05 15:18

reporter   ~0002974

With SOGo 1.3.9 and OS X Lion 10.7.2 I don't get any addresses showing up in "Address Book.app". I have multiple address books, none show up. I do not see all the LDAP addresses but I also wouldn't expect to because I have "isAddressBook = N0;"

I do see this in the soho.log:


2011-11-05 13:30:37.070 sogod[10191] -[WEClientCapabilities initWithRequest:]: Unknown WebClient: user-agent='AddressBook/6.1 (1062) CardDAVPlugin/196 CFNetwork/520.2.5 Mac_OS_X/10.7.2 (11C74)'
sogo.domain.com - - [05/Nov/2011:13:30:37 GMT] "PROPFIND /SOGo/dav/user@domain.com/Contacts/C41878BC-4B80-0001-181F-133C6CCB1A47/ HTTP/1.1" 207 340/121 0.186 1410 75% 8K
2011-11-05 13:30:37.347 sogod[10191] -[WEClientCapabilities initWithRequest:]: Unknown WebClient: user-agent='AddressBook/6.1 (1062) CardDAVPlugin/196 CFNetwork/520.2.5 Mac_OS_X/10.7.2 (11C74)'
sogo.domain.com - - [05/Nov/2011:13:30:37 GMT] "REPORT /SOGo/dav/user@domain.com/Contacts/C41878BC-4B80-0001-181F-133C6CCB1A47/ HTTP/1.1" 207 883/784 0.004 2791 68% 28K
2011-11-05 13:30:37.529 sogod[10191] -[WEClientCapabilities initWithRequest:]: Unknown WebClient: user-agent='AddressBook/6.1 (1062) CardDAVPlugin/196 CFNetwork/520.2.5 Mac_OS_X/10.7.2 (11C74)'
sogo.domain.com - - [05/Nov/2011:13:30:37 GMT] "PROPFIND /SOGo/dav/user@domain.com/Contacts/C41878BC-4B80-0001-181F-133C6CCB1A47/ HTTP/1.1" 207 461/181 0.070 - - 0
2011-11-05 13:30:37.692 sogod[10191] -[WEClientCapabilities initWithRequest:]: Unknown WebClient: user-agent='AddressBook/6.1 (1062) CardDAVPlugin/196 CFNetwork/520.2.5 Mac_OS_X/10.7.2 (11C74)'
sogo.domain.com - - [05/Nov/2011:13:30:37 GMT] "PROPFIND /SOGo/dav/user@domain.com/Contacts/C41878BC-4B80-0001-181F-133C6CCB1A47/ HTTP/1.1" 207 340/121 0.004 1410 75% 0
2011-11-05 13:30:37.786 sogod[10191] -[WEClientCapabilities initWithRequest:]: Unknown WebClient: user-agent='AddressBook/6.1 (1062) CardDAVPlugin/196 CFNetwork/520.2.5 Mac_OS_X/10.7.2 (11C74)'
sogo.domain.com - - [05/Nov/2011:13:30:37 GMT] "REPORT /SOGo/dav/user@domain.com/Contacts/C41878BC-4B80-0001-181F-133C6CCB1A47/ HTTP/1.1" 207 784/359 0.003 - - 0


It looks like the user agent is also unknown. "AddressBook/6.1"

ludovic

ludovic

2011-11-19 07:36

administrator   ~0003044

Someone in a position to try a patch?

Issue History

Date Modified Username Field Change
2011-08-18 16:25 johnsonua New Issue
2011-08-18 16:25 johnsonua File Added: sogo address book bug report.txt
2011-10-26 14:03 francis Target Version => 1.3.10
2011-11-05 15:18 jtclark Note Added: 0002974
2011-11-19 07:36 ludovic Note Added: 0003044
2011-11-21 09:28 ludovic Status new => resolved
2011-11-21 09:28 ludovic Fixed in Version => 1.3.10
2011-11-21 09:28 ludovic Resolution open => fixed
2011-11-21 09:28 ludovic Assigned To => ludovic
2011-11-21 09:28 ludovic Status resolved => closed