View Issue Details

IDProjectCategoryView StatusLast Update
0001407SOGoBackend Generalpublic2013-01-18 14:59
Reportercpohle Assigned Toludovic  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version1.3.8 
Fixed in Version2.0.4 
Summary0001407: LDAP authentication agains ActiveDirectory fails when backslash in distinguishedName
Description

This took me a couple of hours to solve:

We're using LDAP to authenticate users against an ActiveDirectory. Some users authenticated well while others did not at all.

I discovered that the users which did not authenticate had an backslash '\' in their distinguishedName attribute. This is always the case if the users name is defined as "surname, givenName" (like "Doe, John", as is the standard in our organization. Windows automagically escapes the comma to "CN=Doe\, John,OU=..." in the distinguishedName attribute.

Once I renamed the user to 'givenName surname' (e.g., "John Doe"), authentication and logon to the SOGo web interface worked well.

I think this should be fixed in SOGo.

Additional Information

SOGo running on Ubuntu 10.04 LTS

TagsNo tags attached.

Relationships

duplicate of 0002152 closed Users with commas and spaces in their LDAP DNs cannot login 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2011-08-05 05:58 cpohle New Issue
2013-01-18 14:59 ludovic Relationship added duplicate of 0002152
2013-01-18 14:59 ludovic Duplicate ID 0 => 2152
2013-01-18 14:59 ludovic Status new => resolved
2013-01-18 14:59 ludovic Fixed in Version => 2.0.4
2013-01-18 14:59 ludovic Resolution open => duplicate
2013-01-18 14:59 ludovic Assigned To => ludovic