View Issue Details

IDProjectCategoryView StatusLast Update
0001377SOGoWeb Mailpublic2011-12-30 11:41
Reportergienger Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.3.7a 
Fixed in Version1.3.8 
Summary0001377: Content-Transfer-Encoding: binary results in empty message display
Description

SOGo does not understand

Content-Transfer-Encoding: binary

Some automatic mail generators do create this kind of encoding.

RFC 1521 states

  "Binary" means that not only may non-ASCII characters
        be present, but also that the lines are not
        necessarily short enough for SMTP transport.
Additional Information

2011-07-14 14:50:08.674 sogod[22770] encoding 'binary' unknown, returning nil data
Jul 14 14:50:08 sogod [22770]: [ERROR] UIxMailPartTextViewer got no text content: 1

TagsNo tags attached.

Activities

ludovic

ludovic

2011-07-14 08:58

administrator   ~0002706

I pushed a fix a few days a go regarding this. Try a nightly build and/or attach sample messages if you already tried and it still doesn't work.

gienger

gienger

2011-07-14 09:07

reporter   ~0002707

No, I don't have any nightly here, I think I'll stick this to my esteemed collegue Christian Mack.

Christian Mack

Christian Mack

2011-08-17 05:21

developer   ~0002800

Tested with SOGo Version 1.3.8 (root@vizzini.inverse.ca 201107261236).

Works for me.
Can be closed.

Issue History

Date Modified Username Field Change
2011-07-14 08:57 gienger New Issue
2011-07-14 08:58 ludovic Note Added: 0002706
2011-07-14 09:07 gienger Note Added: 0002707
2011-08-17 05:21 Christian Mack Note Added: 0002800
2011-12-30 11:41 ludovic Status new => closed
2011-12-30 11:41 ludovic Resolution open => fixed
2011-12-30 11:41 ludovic Fixed in Version => 1.3.8