View Issue Details

IDProjectCategoryView StatusLast Update
0001365SOGoWeb Calendarpublic2011-07-12 15:08
Reporterdani Assigned Tofrancis  
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.3.7a 
Target Version1.3.8Fixed in Version1.3.8 
Summary0001365: SOGo should not accept empty calendar name
Description

If we rename a existing calendar, emptying its name, SOGo write a null value in the c_foldername database field, which then crash sogod when we try to access to the calendar view

You can find attached the logs

Additional Information

SOGO 1.3.7a (from RPM)
CentOS 5.6 i386

TagsNo tags attached.

Activities

2011-07-12 06:20

 

sogo_erreur_nom_agenda_vide.txt (3,009 bytes)   
2011-07-12 11:17:40.502 sogod[2843] WARNING(-[NSNull(misc) count]): called NSNull -count (returns 0) !!!
localhost - - [12/Jul/2011:11:17:40 GMT] "GET /SOGo/so/user/Calendar//B17-4E1C0F80-17-BA4B480/properties HTTP/1.1" 200 8710/0 0.030 24782 64% 0
2011-07-12 11:17:46.448 sogod[2843] WARNING(-[NSNull(misc) count]): called NSNull -count (returns 0) !!!
localhost - - [12/Jul/2011:11:17:46 GMT] "POST /SOGo/so/user/Calendar//B17-4E1C0F80-17-BA4B480/saveProperties HTTP/1.1" 200 293/177 0.026 - - 0
localhost - - [12/Jul/2011:11:17:47 GMT] "GET /SOGo/so/user/Calendar//B17-4E1C0F80-17-BA4B480/newevent?day=20110711 HTTP/1.1" 302 0/0 0.007 - - 0
localhost - - [12/Jul/2011:11:17:47 GMT] "GET /SOGo/so/user/Calendar/B17-4E1C0F80-17-BA4B480//B1B-4E1C1100-1F-3888534.ics/editAsAppointment?day=20110711 HTTP/1.1" 200 10584/0 0.045 33851 68% 0
localhost - - [12/Jul/2011:11:17:51 GMT] "POST /SOGo/so/user/Calendar/B17-4E1C0F80-17-BA4B480/B1B-4E1C1100-1F-3888534.ics/saveAsAppointment HTTP/1.1" 200 21/874 0.025 - - 0
localhost - - [12/Jul/2011:11:17:52 GMT] "POST /SOGo/so/user/Calendar/alarmslist?browserTime=1310462279 HTTP/1.1" 200 2/0 0.007 - - 0
EXCEPTION: <NSException: 0xa118460> NAME:NSInvalidArgumentException REASON:Tried to add nil value for key 'calendarName' to dictionary INFO:{c_category = "<null>"; c_classification = 0; c_component = vevent; c_content = "BEGIN:VCALENDAR
VERSION:2.0
PRODID:-//Inverse inc./SOGo 1.3.7//EN
BEGIN:VEVENT
UID:B1B-4E1C1100-1F-3888534
SUMMARY:blabla
CREATED:20110712T091751Z
DTSTAMP:20110712T091751Z
LAST-MODIFIED:20110712T091751Z
DTSTART;TZID=/inverse.ca/20101018_1/Europe/Paris:20110711T080000
DTEND;TZID=/inverse.ca/20101018_1/Europe/Paris:20110711T090000
TRANSP:OPAQUE
END:VEVENT
BEGIN:VTIMEZONE
TZID:/inverse.ca/20101018_1/Europe/Paris
X-LIC-LOCATION:Europe/Paris
BEGIN:DAYLIGHT
TZOFFSETFROM:+0100
TZOFFSETTO:+0200
TZNAME:CEST
DTSTART:19700329T020000
RRULE:FREQ=YEARLY;BYMONTH=3;BYDAY=-1SU
END:DAYLIGHT
BEGIN:STANDARD
TZOFFSETFROM:+0200
TZOFFSETTO:+0100
TZNAME:CET
DTSTART:19701025T030000
RRULE:FREQ=YEARLY;BYMONTH=10;BYDAY=-1SU
END:STANDARD
END:VTIMEZONE
END:VCALENDAR"; c_creationdate = 1310462271; c_cycleinfo = "<null>"; c_enddate = 1310367600; c_folder = "B17-4E1C0F80-17-BA4B480"; c_isallday = 0; c_iscycle = 0; c_isopaque = 1; c_lastmodified = 1310462271; c_location = ""; c_name = "B1B-4E1C1100-1F-3888534.ics"; c_nextalarm = 0; c_orgmail = ""; c_owner = user; c_participants = "<null>"; c_partmails = "<null>"; c_partstates = ""; c_priority = 0; c_sequence = 0; c_startdate = 1310364000; c_status = 1; c_title = blabla; c_uid = "B1B-4E1C1100-1F-3888534"; c_version = 0; editable = 1; endDate = "2011-07-11 07:00:00 +0000"; erasable = 1; ownerIsOrganizer = 0; startDate = "2011-07-11 06:00:00 +0000"; }
Jul 12 11:17:52 sogod [2806]: <0x0x8cfa2f8[WOWatchDogChild]> child 2841 exited
Jul 12 11:17:52 sogod [2806]: <0x0x8cfa2f8[WOWatchDogChild]>  (terminated due to signal 6)
Jul 12 11:17:52 sogod [2806]: <0x0x8d70ce8[WOWatchDog]> child spawned with pid 24568

francis

francis

2011-07-12 15:07

administrator   ~0002694

Fixed with revision 1e456d9a08ec90bd4e7fad4909eecfaa354aed5a.

Issue History

Date Modified Username Field Change
2011-07-12 06:20 dani New Issue
2011-07-12 06:20 dani File Added: sogo_erreur_nom_agenda_vide.txt
2011-07-12 14:37 francis Status new => assigned
2011-07-12 14:37 francis Assigned To => francis
2011-07-12 14:38 francis Target Version => 1.3.8
2011-07-12 15:07 francis Note Added: 0002694
2011-07-12 15:07 francis Status assigned => resolved
2011-07-12 15:07 francis Fixed in Version => 1.3.8
2011-07-12 15:07 francis Resolution open => fixed