View Issue Details

IDProjectCategoryView StatusLast Update
0001339SOGoApple iPhone OSpublic2011-12-30 14:42
Reportermzeedijk Assigned Toludovic  
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionfixed 
Product Version1.3.7 
Target Version1.3.12Fixed in Version1.3.12 
Summary0001339: Photo problem on iPhone
Description

When a photo is attached to a contact on the iPhone contact sync failed from then on and will not be synced again untill the photo is removed from the contact. The error in the logs looks like this

Jun 15 10:44:56 sogod [8415]: [ERROR] <0x09BCE868[SOGoContactGCSEntry]:C4C40B0C-73E0-0001-F24B-1F9E11001FA6.vcf> write failed: <PostgreSQL72Exception: 0x96b5550> NAME:PostgreSQL72FatalError REASON:fatal pgsql error (channel=<0x0x943de68[PostgreSQL72Channel]: connection=<0x0x97715f0[PGConnection]: connection=0x0x9a43190>>): ERROR: value too long for type character varying(100000)

This is due to the photo being to big to fit in the column c_content. This column is of type character varying(100000), thus 100 kB is reserved for the contact VCARD which includes also the photo data. In this case the photo is jpeg data so it's possible that it doens't always fail depending on the amount of compression done on the jpeg. But most photos I attached to a contact on the iPhone were about 150kB in size in the VCARD data.

imo there are 2 ways to fix this.
preferred: Change type of c_content to text so it will always fit
deprecated:enlarge c_content from character varying(100000) to eg. character varying(500000) or even character varying(1000000).

For people who are having these problems with contacts, you can actually easily manually change this through eg. pgadmin (in case of postgresql) or phpmyadmin (incase of mySQL).

It works for me by setting the type to text.

TagsNo tags attached.

Issue History

Date Modified Username Field Change
2011-06-15 04:57 mzeedijk New Issue
2011-12-12 13:31 francis Target Version => 1.3.12
2011-12-30 14:42 ludovic Note Added: 0003242
2011-12-30 14:42 ludovic Status new => resolved
2011-12-30 14:42 ludovic Fixed in Version => 1.3.12
2011-12-30 14:42 ludovic Resolution open => fixed
2011-12-30 14:42 ludovic Assigned To => ludovic
2011-12-30 14:42 ludovic Status resolved => closed