View Issue Details

IDProjectCategoryView StatusLast Update
0001312SOGoWeb Calendarpublic2011-06-17 17:12
ReporterMarten Gajda Assigned Toludovic  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.3.6 
Target Version1.3.8Fixed in Version1.3.8 
Summary0001312: DURATION not properly set when changing existing event to all-day event
Description

When a non-all-day event with DURATION attribute (instead of DTEND) is changed to an all-day event in the web calendar, the DURATION attribute is left unchanged but an DTEND attribute is added.

This leads to the following event

BEGIN:VCALENDAR
VERSION:2.0
PRODID:-//dmfs.org//mimedir/icalendar//EN
BEGIN:VEVENT
DTSTART:20110526
SUMMARY:REC EVENT2c
TRANSP:OPAQUE
STATUS:TENTATIVE
DURATION:PT1H
LAST-MODIFIED:20110519T131338Z
CREATED:20110511T212853Z
DTSTAMP:20110511T212853Z
UID:a970c27c-00b5-4f90-8c24-e73049fc88fd
RRULE:FREQ=WEEKLY;BYDAY=MO,TU,WE,TH,FR
DTEND:20110527
SEQUENCE:1
END:VEVENT

which is obviously broken (all-day event with a DURATION of one hour).

I tested it with recurring events only, single instance events my be affected as well.

Note: the original event was created by my CalDAV-Sync adapter for Android (which always sets a duration for recurring events instead of dtend). It was synced correctly and later changed to all-day via SOGo's web calendar.

TagsNo tags attached.

Activities

Marten Gajda

Marten Gajda

2011-05-19 09:43

reporter   ~0002496

If changed back to a non-all-day event the DURATION seems to be updated properly and the DTEND is removed

ludovic

ludovic

2011-06-17 17:11

administrator   ~0002602

http://mtn.inverse.ca/revision/diff/a1ae082f345f010ed0903ee2ac6873682313ca49/with/9c23081be1d521d038cc4cbf8d2034a12fca88aa

ludovic

ludovic

2011-06-17 17:12

administrator   ~0002603

Reminder sent to: jraby

A unit test should be written for this over DAV.

Issue History

Date Modified Username Field Change
2011-05-19 09:26 Marten Gajda New Issue
2011-05-19 09:43 Marten Gajda Note Added: 0002496
2011-06-15 16:35 ludovic Status new => assigned
2011-06-15 16:35 ludovic Assigned To => ludovic
2011-06-15 16:35 ludovic Target Version => 1.3.8
2011-06-17 17:11 ludovic Note Added: 0002602
2011-06-17 17:11 ludovic Status assigned => resolved
2011-06-17 17:11 ludovic Fixed in Version => 1.3.8
2011-06-17 17:11 ludovic Resolution open => fixed
2011-06-17 17:12 ludovic Note Added: 0002603