View Issue Details

IDProjectCategoryView StatusLast Update
0001291SOGoWeb Mailpublic2011-05-06 10:55
Reporterfrancis Assigned Toludovic  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Target Version1.3.7aFixed in Version1.3.7a 
Summary0001291: IMAP namespace support - SOGo crashes with a NSRangeException
Description

When dealing with a Dovecot IMAP server, SOGo crashes :

EXCEPTION: <NSException: 0x9ff2a58> NAME:NSRangeException REASON:Index 2 is out of range 2 (in 'objectAtIndex:') INFO:{Array = ("/", shared); Count = 2; Index = 2; }
May 04 15:33:20 sogod [4758]: <0x0x9c41230[WOWatchDogChild]> child 5070 exited
May 04 15:33:20 sogod [4758]: <0x0x9c41230[WOWatchDogChild]> (terminated due to signal 6)

TagsNo tags attached.

Activities

francis

francis

2011-05-06 10:55

administrator   ~0002440

Fixed in revision 60ea6e18203007e12287f19ec553de192b334dd6.

Issue History

Date Modified Username Field Change
2011-05-06 10:55 francis New Issue
2011-05-06 10:55 francis Status new => assigned
2011-05-06 10:55 francis Assigned To => ludovic
2011-05-06 10:55 francis Note Added: 0002440
2011-05-06 10:55 francis Status assigned => resolved
2011-05-06 10:55 francis Fixed in Version => 1.3.7a
2011-05-06 10:55 francis Resolution open => fixed