View Issue Details

IDProjectCategoryView StatusLast Update
0001255SOGoBackend Calendarpublic2011-04-15 21:35
Reporterpierre Assigned Tofrancis  
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version1.3.5 
Fixed in Version1.3.7 
Summary0001255: Events with no ENDDT: in ics File
Description

When loading calendar with no ENDDT: , nothing is loaded in SOGo, Lightning, and a iPhone.
Sogo is restarting when the bad event is loaded.
Maybe thoses events have been modified with an iphone, but i can't test that.
Whe can see that there are recurrent events.

Additional Information

The 3 bad events in ics format :

BEGIN:VEVENT
LAST-MODIFIED:20110404T081850Z
DTSTAMP:20110404T081850Z
UID:e61e2e99-f36f-4fb6-9c55-879f67e6125c
SUMMARY:RĂ©union hebdo
RRULE:FREQ=WEEKLY;BYDAY=MO
X-MOZ-LASTACK:20110404T081850Z
DTSTART;TZID=Europe/Paris:20110131T093000
X-MICROSOFT-CDO-ALLDAYEVENT:FALSE
X-ORACLE-EVENTTYPE:APPOINTMENT
X-MOZ-GENERATION:7
BEGIN:VALARM
ACTION:DISPLAY
TRIGGER;VALUE=DURATION:-PT10M
DESCRIPTION:RĂ©union hebdo
END:VALARM
END:VEVENT

BEGIN:VEVENT
UID:6f640ba0-0281-434a-b791-f4289efb37f8
SUMMARY:(og) point BU / Pessac
X-MICROSOFT-CDO-ALLDAYEVENT:FALSE
X-ORACLE-EVENTTYPE:APPOINTMENT
DTSTART;TZID=Europe/Paris:20110422T113000
DTSTAMP:20110401T192641Z
RRULE:FREQ=WEEKLY;UNTIL=20110617T093000Z;INTERVAL=4;BYDAY=FR
BEGIN:VALARM
ACTION:DISPLAY
TRIGGER:-PT10M
DESCRIPTION:(og) point BU / Pessac
END:VALARM
END:VEVENT

BEGIN:VEVENT
UID:388ef410-ec89-48d0-8691-41c15f84eb8f
SUMMARY:(og) point projets Patricia
X-MICROSOFT-CDO-ALLDAYEVENT:FALSE
X-ORACLE-EVENTTYPE:APPOINTMENT
DTSTART;TZID=Europe/Paris:20110408T113000
DTSTAMP:20110401T192630Z
RRULE:FREQ=WEEKLY;UNTIL=20110603T093000Z;INTERVAL=4;BYDAY=FR
BEGIN:VALARM
ACTION:DISPLAY
TRIGGER:-PT10M
DESCRIPTION:(og) point projets Patricia
END:VALARM
END:VEVENT

TagsNo tags attached.

Activities

pierre

pierre

2011-04-12 05:33

reporter   ~0002372

Last edited: 2011-04-12 07:05

I forgot informations :
The calendar was functionnal well in SOGo, but the problem is comming when an event was modified (maybe?) whith a iPhone.

I have this in logs :
2011-04-12 11:31:59.940 sogod[8600] NGCalendarDateRange.m:38 Assertion failed in NGCalendarDateRange(instance), method initWithStartDate:endDate:. endDate MUST NOT be nil!
EXCEPTION: <NSException: 0x851e4d8> NAME:NSInternalInconsistencyException REASON:NGCalendarDateRange.m:38 Assertion failed in NGCalendarDateRange(instance), method initWithStartDate:endDate:. endDate MUST NOT be nil! INFO:(

francis

francis

2011-04-15 16:51

administrator   ~0002389

FYI -- I noticed that some versions of the CalDAV client of Hypermatix (for Android) also create events with no end date nor duration.

francis

francis

2011-04-15 21:35

administrator   ~0002390

Fixed in revision 12a15fd8afcf3963e3ec84c6a630972534773465.

Issue History

Date Modified Username Field Change
2011-04-12 04:37 pierre New Issue
2011-04-12 05:33 pierre Note Added: 0002372
2011-04-12 07:05 pierre Note Edited: 0002372
2011-04-14 21:49 francis Status new => assigned
2011-04-14 21:49 francis Assigned To => francis
2011-04-15 16:51 francis Note Added: 0002389
2011-04-15 21:35 francis Note Added: 0002390
2011-04-15 21:35 francis Status assigned => resolved
2011-04-15 21:35 francis Fixed in Version => 1.3.7
2011-04-15 21:35 francis Resolution open => fixed