View Issue Details

IDProjectCategoryView StatusLast Update
0000119SOGoBackend Generalpublic2009-08-27 15:26
Reporterbugreporter Assigned Toludovic  
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.0.4 
Fixed in Version1.1.0 
Summary0000119: WOPort
Description

The documentation says that setting WOPort in the .GNUstep file is optional as it defaults to port 20000. However, when I do not set this parameter, SOGo does not work -- I get the error:

Aug 24 16:56:12 sogod [30569]: [ERROR] |SOGo| got no address for HTTP server (using arg '(nil)')

Setting WOPort fixes the problem, so I think just the documentation needs to be changed.

TagsNo tags attached.

Activities

ludovic

ludovic

2009-08-25 09:10

administrator   ~0000103

I don't think that's the problem.

The problem is likely coming from a broken script that starts the sogod process with no -WOPort argument. Look for this.

bugreporter

bugreporter

2009-08-25 11:07

reporter   ~0000104

I'm running off the 1.0.4 debian packages and their init script. It looks like sogod is being run with the -WOPort 20000 option:

$ ps aux|grep sog
sogo 16680 0.0 1.2 21232 2408 ? S 06:27 0:00 /usr/sbin/sogod -WOPort 20000
sogo 16698 0.0 6.0 52428 11436 ? S 06:27 0:07 /usr/sbin/sogod -WOPort 20000

ludovic

ludovic

2009-08-27 15:26

administrator   ~0000105

http://mtn.inverse.ca/revision/diff/a8698cc119066cef660b176c3e956b5d0d843e7f/with/4a2351cfd0ee0b84e1abe4b32284c6d363471ef3

Issue History

Date Modified Username Field Change
2009-08-24 18:57 bugreporter New Issue
2009-08-25 09:10 ludovic Note Added: 0000103
2009-08-25 11:07 bugreporter Note Added: 0000104
2009-08-25 16:26 francis Summary WO => WOPort
2009-08-27 15:26 ludovic Note Added: 0000105
2009-08-27 15:26 ludovic Status new => resolved
2009-08-27 15:26 ludovic Fixed in Version => 1.1.0
2009-08-27 15:26 ludovic Resolution open => fixed
2009-08-27 15:26 ludovic Assigned To => ludovic