View Issue Details

IDProjectCategoryView StatusLast Update
0001166SOGoSOPEpublic2011-06-16 11:38
Reporterbuzzdee Assigned Toludovic  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.3.5 
Target Version1.3.8Fixed in Version1.3.8 
Summary0001166: WOHTTPURLHandle.m doesn't implement cachedHandleForURL
Description

I'm right now testing opengroupware against sope-1.3.5.
When I have the geocoding and mapping enabled for the addresses there, and click on the map button to map the users in the list from a search result, then I run into an exception. After some digging I found that subclasses of NSURLHandle are supposed to implement:
+[WOHTTPURLHandle cachedHandleForURL:]

since it is not implemented in WOHTTPURLHandle, OGo freaks out ;)

I took a look what NSHTTPURLHandle is doing, and found that it returns nil, if it cannot find sth. in its cache.
Attached patch just implements this class method, always returning nil, so there is no caching for those URLs.

Additional Information

I guess SOGo is not using WOHTTPURLHandle, but please review this patch and add it or sth. similar for the 1.3.6 release of SOPE.

TagsNo tags attached.

Activities

2011-03-03 13:27

 

patch-sope-appserver_NGObjWeb_WOHTTPURLHandle_m (695 bytes)   
$OpenBSD$

Implement missing subclass, trying to fix exception when clicking the map button on ogo contacts

--- sope-appserver/NGObjWeb/WOHTTPURLHandle.m.orig	Thu Mar  3 15:10:02 2011
+++ sope-appserver/NGObjWeb/WOHTTPURLHandle.m	Thu Mar  3 15:12:28 2011
@@ -50,6 +50,14 @@
   return [[_url scheme] isEqualToString:@"http"];
 }
 
++ (NSURLHandle*) cachedHandleForURL: (NSURL*)newUrl
+{
+  NSURLHandle   *obj = nil;
+  NSLog(@"NOTE: WOHTTPURLHandle.m: cachedHandleForURL: caching not yet not yet implemented");
+  return obj;
+}
+
+
 - (id)initWithURL:(NSURL *)_url cached:(BOOL)_flag {
   if (![[_url scheme] hasPrefix:@"http"]) {
     NSLog(@"%s: invalid URL scheme %@ for WOHTTPURLHandle !",
buzzdee

buzzdee

2011-04-13 07:37

reporter   ~0002374

could this be reviewed and commented, or even included if its fine? Shortly after a release is a good time to add new stuff, since the plenty of time for testing till the next release ;)

ludovic

ludovic

2011-06-16 11:38

administrator   ~0002590

Patch pushed: http://mtn.inverse.ca/revision/diff/b904302ec7f7663496c7a17492fc8767c1a1b674/with/856965845eee02997e104f46f22a199238f9ed24

Issue History

Date Modified Username Field Change
2011-03-03 13:27 buzzdee New Issue
2011-03-03 13:27 buzzdee File Added: patch-sope-appserver_NGObjWeb_WOHTTPURLHandle_m
2011-03-03 19:33 ludovic Status new => assigned
2011-03-03 19:33 ludovic Assigned To => ludovic
2011-04-13 07:37 buzzdee Note Added: 0002374
2011-06-15 16:56 ludovic Target Version => 1.3.8
2011-06-16 11:38 ludovic Note Added: 0002590
2011-06-16 11:38 ludovic Status assigned => resolved
2011-06-16 11:38 ludovic Fixed in Version => 1.3.8
2011-06-16 11:38 ludovic Resolution open => fixed