View Issue Details

IDProjectCategoryView StatusLast Update
0001144SOGoWeb Calendarpublic2011-03-10 17:22
ReporterMSmiatek Assigned Tofrancis  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.3.5 
Target Version1.3.6Fixed in Version1.3.6 
Summary0001144: All day Event shown for two days
Description

when i add a "All day Event" in Lightning
SOGo's Webinterface shows that Event on two Days.

TagsNo tags attached.

Activities

firedup

firedup

2011-02-27 22:05

reporter   ~0002170

I have observed this behavior as well. This is while using SOGo v1.3.5a.

Any all day events added directly via the SOGo web interface works and looks fine.
However, all day events added via an external Caldav client is displayed across two days in the Web interface. The events look and behave normally in the Caldav client interface.
E.g. All day event created for Mar 13, 2011, will show on Mar 12, 2011 and Mar 13,2011 as all day events in the SOGo web interface.

I have verified this behavior while using Thunderbird 3.1 with the SOGo lightning, connector and integrator (linux), Thunderbird 3.1 with SOGo lightning, connector and integrator (on Mac), Sunbird on Linux and iCal on Mac.

A brief inspection of the database seems to point to the fact that the SOGo web interface appears to think that the event in the above example starts at 7:00pm on Mar 12 and ends at 6:59pm on Mar 13, instead of 12:00am/11:59pm on March 13 as a typical all day event will have. This suggests a timezone related issue since I am operating on America/New_York timezone.

Upon pressing the edit window for this event in SOGo web interface, the start and end dates shown are correct (Mar 13 2011).

--FiredUp

wimmer

wimmer

2011-02-28 02:54

reporter   ~0002171

I can confirm this issue on my site.
It is the same when all day event is created in TH3.1 and TH2.

ccb23

ccb23

2011-03-02 05:15

reporter   ~0002180

I see the same issue, when I add a 3 day-event in Mac OS X Calendar.app:
the 3-whole-day event is shown as a 4-day event in SOGo-Web.
(When I double-click the event I see the correct begin and end dates, equal to the dates I entered in the Mac OS X client)

Maybe it is a timezone issue?

francis

francis

2011-03-10 17:22

administrator   ~0002246

Fixed in revision a15dbfb88dbe373949a0883880ab6b6e0175e72b.

Issue History

Date Modified Username Field Change
2011-02-21 07:00 MSmiatek New Issue
2011-02-27 22:05 firedup Note Added: 0002170
2011-02-28 02:54 wimmer Note Added: 0002171
2011-03-02 05:15 ccb23 Note Added: 0002180
2011-03-02 06:34 ludovic Target Version => 1.3.6
2011-03-03 08:45 francis Status new => assigned
2011-03-03 08:45 francis Assigned To => francis
2011-03-10 17:22 francis Note Added: 0002246
2011-03-10 17:22 francis Status assigned => resolved
2011-03-10 17:22 francis Fixed in Version => 1.3.6
2011-03-10 17:22 francis Resolution open => fixed