View Issue Details

IDProjectCategoryView StatusLast Update
0000113SOGoWeb Mailpublic2009-10-22 20:38
Reporterfrancis Assigned Touser4 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.0.4 
Target Version1.1.0Fixed in Version1.1.0 
Summary0000113: MailFieldNames are ignored when composing email with saved preferences
Description
  1. Configure SOGo with a LDAP source with at least two attributes in MailFieldNames;
  2. Login with a user that has at least two email addresses;
  3. Compose an email -- all the user's addresses will be available in the "From" popup menu;
  4. Visit the preferences window -- click on the "Save and Close" button;
  5. Compose a new email -- only the main email address will be available.

The bug comes from the MailAccounts/identities defined in the user settings when saving the preferences. We should simply remove this setting for now.

TagsNo tags attached.

Activities

user4

2009-08-20 16:35

  ~0000100

I fixed it for the case where the "mail" field has more than one value, but I couldn't reproduce the error with the method described.
Could someone give it a try and see if it fixed it?

ludovic

ludovic

2009-10-21 09:24

administrator   ~0000239

This has been fixed a little while ago.

Issue History

Date Modified Username Field Change
2009-08-20 14:44 francis New Issue
2009-08-20 14:44 francis Status new => assigned
2009-08-20 14:44 francis Assigned To => user4
2009-08-20 16:35 user4 Note Added: 0000100
2009-08-20 16:35 user4 Status assigned => confirmed
2009-10-21 09:24 ludovic Note Added: 0000239
2009-10-21 09:24 ludovic Status confirmed => resolved
2009-10-21 09:24 ludovic Fixed in Version => 1.1.0
2009-10-21 09:24 ludovic Resolution open => fixed
2009-10-22 20:38 francis Target Version 1.0.5 => 1.1.0