View Issue Details

IDProjectCategoryView StatusLast Update
0001129SOGoBackend Mailpublic2012-11-30 16:16
Reportermra Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.3.5 
Fixed in Version2.0.3 
Summary0001129: Using filter with flagging breaks all sieve-scripts
Description

After using a filter with imapflagging all sieve dependend functions like vacation and the other filters are defect, the sieve script cannot be compiled anymore and the SOGo-Log shows entries like

Feb 09 10:23:18 sogod [11721]: [ERROR] <0x0980C1F8[SOGoMailAccount]:0> Could not upload Sieve script: {RawResponse = "{ok = NO; reason = \"sogo: line 1: error: require command: unknown Sieve capability 'imapflags'.
sogo: line 20: error: unknown command 'addflag' (only reported once at first occurence).
sogo: error: validation failed.
\"; }"; result = NO; }

This error was found on a Dovecot-1.2-Machine.
Dovecot uses only the Rfc-conform "imap4flags" module, the cmusieve-compatible "imapflags"-module has to be enabled by adding
sieve_extensions = +imapflag
to the dovecot-configuration.

But, managesieve shows up its capabilities and tells sogo, it uses imap4flags.
So, it would be a solution to test for the capabilities and use imapflags or imap4flags (since it is part of the newer RFC of sieve and imapflags is marked as deprecated).

Other solution: put a switch like "use_cmusieve" (YES/NO) into the SOGo-config so SOGo knows, which modules are available.

Side action: the incident 0000676 could be (partly) solved - without cmusieve (which cannot handle the date-extension)

Additional Information

http://wiki.dovecot.org/LDA/Sieve/Dovecot#Migration_from_CMUSieve

TagsNo tags attached.

Activities

ludovic

ludovic

2012-11-30 16:16

administrator   ~0005013

This is now fixed. Please try a nightly build, which should be available in about 12 hours.

Issue History

Date Modified Username Field Change
2011-02-09 04:56 mra New Issue
2012-11-30 16:16 ludovic Note Added: 0005013
2012-11-30 16:16 ludovic Status new => closed
2012-11-30 16:16 ludovic Resolution open => fixed
2012-11-30 16:16 ludovic Fixed in Version => 2.0.3