View Issue Details

IDProjectCategoryView StatusLast Update
0001051SOGoBackend Calendarpublic2011-07-06 15:32
Reporterbertails Assigned Toludovic  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version1.3.4 
Summary0001051: can't move an event between 2 calendars from iCal
Description

A user create an event in a first calendar:
[[
127.0.0.1 - - [10/Dec/2010:11:58:20 GMT] "PUT /SOGo/dav/XXX/Calendar/4FB4-4D024500-5FB-65B24280/E7EDE123-4019-4CD8-BE88-03B24B642CB6.ics HTTP/1.1" 201 0/832 0.020 - - 0
]]

Then the user tried to change the calender associated with this event:
[[
Dec 10 11:58:25 sogod [21040]: [obj-dav-dispatch] tried to do a cross server move (https://cal-dev.w3.org vs https://cal-dev.w3.org/SOGo/dav/XXX/Calendar/personal/E7EDE123-4019-4CD8-BE88-03B24B642CB6.ics)
]]

Additional Information

The traditional cut-and-paste work (DELETE + PUT)

TagsNo tags attached.

Relationships

duplicate of 0001096 closedludovic iCal from Mac OS X 10.6 - can't move events between calendars - CalDAVMoveEntityQueueableOperation 

Activities

ndl

ndl

2010-12-23 10:04

reporter   ~0001962

Happens for me too: iCal 4.0.4 (1395), SOGo 1.3.4

This is quite annoying as it breaks the typical workflow: if the invitation sent via e-mail is added to the wrong calendar, there's no way (via iCal interface, at least) to move it to the other calendar because DELETE +PUT workaround suggested above is not an option as in this case meeting organizer would receive "declined" response.

ludovic

ludovic

2010-12-23 10:45

administrator   ~0001963

The WebDAV MOVE operation needs to be added to support this. We'll look into it.

tolivier

tolivier

2011-05-25 10:56

reporter   ~0002502

issue still exists

+1

mark

mark

2011-05-26 05:13

reporter   ~0002503

This is a big problem - When will it be fixed?

Issue History

Date Modified Username Field Change
2010-12-10 18:56 bertails New Issue
2010-12-23 10:04 ndl Note Added: 0001962
2010-12-23 10:45 ludovic Note Added: 0001963
2011-05-25 10:56 tolivier Note Added: 0002502
2011-05-26 05:13 mark Note Added: 0002503
2011-07-06 15:32 ludovic Relationship added duplicate of 0001096
2011-07-06 15:32 ludovic Duplicate ID 0 => 1096
2011-07-06 15:32 ludovic Status new => resolved
2011-07-06 15:32 ludovic Resolution open => duplicate
2011-07-06 15:32 ludovic Assigned To => ludovic