View Issue Details

IDProjectCategoryView StatusLast Update
0001048SOGoWeb Generalpublic2010-12-08 09:30
Reporterpaubry Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product Version1.3.4 
Summary0001048: Quit button still appears when SOGoCASLogoutEnabled is set to NO
Description

UIxPageFrame.canLogoff() returns TRUE when using CAS authentication with SOGoCASLogoutEnabled set to NO (since in this case it still looks at the auth cookie).
Patch attached.
Best,
PA

TagsNo tags attached.

Relationships

duplicate of 0000953 resolvedludovic Logout button available when using CAS 

Activities

2010-12-08 05:03

 

patch-1.3.4-QuitButton.txt (977 bytes)   
diff -Nbaur --exclude=config.make --exclude=configure --exclude='SOGoCASSession.*' --exclude='LDAPSource.*' --exclude='SOGoUserManager.*' --exclude='*.css' --exclude='SOGoSystemDefaults.*' SOGo-1.3.4-dist/UI/Common/UIxPageFrame.m SOGo-1.3.4/UI/Common/UIxPageFrame.m
--- SOGo-1.3.4-dist/UI/Common/UIxPageFrame.m	2010-11-17 17:30:03.000000000 +0100
+++ SOGo-1.3.4/UI/Common/UIxPageFrame.m	2010-12-08 09:27:51.000000000 +0100
@@ -458,9 +466,10 @@
   if ([auth respondsToSelector: @selector (cookieNameInContext:)])
     {
       sd = [SOGoSystemDefaults sharedSystemDefaults];
-      canLogoff = (([[sd authenticationType] isEqualToString: @"cas"]
-                    && [sd CASLogoutEnabled])
-                   || [[auth cookieNameInContext: context] length] > 0);
+      if ([[sd authenticationType] isEqualToString: @"cas"])
+	canLogoff = [sd CASLogoutEnabled];
+      else
+	canLogoff = [[auth cookieNameInContext: context] length] > 0;
     }
   else
     canLogoff = NO;
patch-1.3.4-QuitButton.txt (977 bytes)   
wsourdeau

wsourdeau

2010-12-08 09:30

viewer   ~0001935

Dup of 0000953

Issue History

Date Modified Username Field Change
2010-12-08 05:03 paubry New Issue
2010-12-08 05:03 paubry File Added: patch-1.3.4-QuitButton.txt
2010-12-08 09:30 wsourdeau Note Added: 0001935
2010-12-08 09:30 wsourdeau Status new => closed
2010-12-08 09:30 wsourdeau Resolution open => duplicate
2010-12-08 09:30 wsourdeau Relationship added duplicate of 0000953
2012-11-06 08:10 ludovic Relationship added has duplicate 0002091
2012-11-06 08:10 ludovic Relationship deleted has duplicate 0002091