View Issue Details

IDProjectCategoryView StatusLast Update
0001047SOGoBackend Mailpublic2016-12-30 13:57
Reportergienger Assigned Toludovic  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.3.4 
Target VersionsoonFixed in Version3.2.5 
Summary0001047: lowercase-header-files triggers spam filters
Description

Google Desktop does not honor lower case headers ("from:", "reply-to:"),
and mails being sent to google mail are often being put to the Spam folders or do never arrive in the mailbox - even if we have a confirmation (smtp dialogue with google says google accepted the message).

The same occurs with web.de in Germany, but I'll inquiry them before (with our smtp log).

Does anybody out there have found the same behaviour?

TagsNo tags attached.

Relationships

duplicate of 0002091 resolvedludovic Mail header fields not according to rfc2822 section-2.2.3 / 3.6. 

Activities

wsourdeau

wsourdeau

2010-12-08 09:37

viewer   ~0001937

dev: I suggest to keep all the internal handling of headers in lower-case, as they are used as keys in dictionaries. The capitalization should be done at the output.

Another case of standard violation...

Fuchur

Fuchur

2012-11-06 14:31

reporter   ~0004783

@waourdeau
So who is violating the standard?

I filled a bug under 2091 which seems to suggest soho should change its output to comply.
At least this will solve the issues with many mail clients either marking it as spam or engines not parsing the mail correctly.

@dev this bug is quite old. Mine 2 years later is said to be a duplicate.
Can you suggest a solution? Will it come from you or don't you agree to the bug?
Do we need to apply a patch ourselves in that case?

Thanks.

ludovic

ludovic

2012-11-06 14:32

administrator   ~0004784

I've targeted that bug as "soon", so we'll likely look at it in v2.0.4 or v2.0.5.

Most of the brain damage around this bug is located in SOPE.

Fuchur

Fuchur

2012-11-06 14:35

reporter   ~0004785

Thanks for the quick feedback!
Love SOGo

dani

dani

2013-03-15 08:29

reporter   ~0005421

I just noticed this problem. For now, I had to write a qpsmtpd plugin to rewrite headers with the correct case (https://wikit.firewall-services.com/doku.php?id=tuto:ipasserelle:mail:corriger_la_casse_des_entetes_sogo)

Christian Mack

Christian Mack

2013-11-28 09:25

developer   ~0006307

This bug is set to soon for more than a year now.
Any updates?

ludovic

ludovic

2013-12-02 14:00

administrator   ~0006321

While adding Active Sync support in SOGo, we're fixing this pure mess in SOPE.

ludovic

ludovic

2016-12-30 13:57

administrator   ~0011146

https://github.com/inverse-inc/sope/commit/c96d96d56f546321e807b5baa85ed707336aeb44

Issue History

Date Modified Username Field Change
2010-12-07 13:36 gienger New Issue
2010-12-08 09:37 wsourdeau Note Added: 0001937
2012-11-06 08:10 ludovic Relationship added duplicate of 0002091
2012-11-06 08:11 ludovic Target Version => soon
2012-11-06 14:31 Fuchur Note Added: 0004783
2012-11-06 14:32 ludovic Note Added: 0004784
2012-11-06 14:35 Fuchur Note Added: 0004785
2013-03-15 08:29 dani Note Added: 0005421
2013-11-28 09:25 Christian Mack Note Added: 0006307
2013-12-02 14:00 ludovic Note Added: 0006321
2016-12-30 13:57 ludovic Note Added: 0011146
2016-12-30 13:57 ludovic Status new => resolved
2016-12-30 13:57 ludovic Fixed in Version => 3.2.5
2016-12-30 13:57 ludovic Resolution open => fixed
2016-12-30 13:57 ludovic Assigned To => ludovic