Relationship Graph

Relationship Graph
related to related to child of child of duplicate of duplicate of

View Issue Details

IDProjectCategoryView StatusLast Update
0002099SOGoBackend Address Bookpublic2013-01-09 11:54
Reporterperelandra Assigned Tofrancis  
PrioritynormalSeveritytweakReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version2.0.2 
Target Version2.0.4Fixed in Version2.0.4 
Summary0002099: Can't use CardDAV with Addressbook of Mac OS X 10.8 again
Description

When trying to connect to a SOGo server with CardDAV and Addressbook of Mac OS X 10.8 aka Mountain Lion, this fails again.

It is related to the following bugs:

http://www.sogo.nu/bugs/bug_view_advanced_page.php?bug_id=1957
http://www.sogo.nu/bugs/view.php?id=1913

TagsNo tags attached.

Relationships

has duplicate 0002017 closed Can't use CardDAV and CalDAV with Mac OS X 10.8.2 

Activities

cxbell

cxbell

2012-11-17 06:06

reporter   ~0004868

I'm having the same issue, Mountain Lion (10.8.2) address book, no settings have changed on my mac, but now the address book has vanished, watching the logs on the server, it never tries to access the personal address book, just looks at the groups and then stops. No error messages present.

francis

francis

2012-11-19 12:24

administrator   ~0004913

Try to delete and re-add the account from Contacts.app.

perelandra

perelandra

2012-11-20 10:48

reporter   ~0004936

Last edited: 2012-11-20 10:50

Delete and re-add makes no difference:

sogo.log says:

127.0.0.1 - - [20/Nov/2012:16:42:39 GMT] "OPTIONS /SOGo/dav/myaccount/ HTTP/1.1" 401 0/0 0.011 - - 0
127.0.0.1 - - [20/Nov/2012:16:42:39 GMT] "OPTIONS /SOGo/dav/myaccount/ HTTP/1.1" 200 0/0 0.009 - - 0
127.0.0.1 - - [20/Nov/2012:16:42:39 GMT] "PROPFIND /SOGo/dav/myaccount/ HTTP/1.1" 207 521/439 0.010 1607 67% 0
127.0.0.1 - - [20/Nov/2012:16:42:40 GMT] "OPTIONS /SOGo/dav/myaccount/ HTTP/1.1" 200 0/0 0.004 - - 0
127.0.0.1 - - [20/Nov/2012:16:42:40 GMT] "PROPFIND /SOGo/dav/myaccount/Contacts/ HTTP/1.1" 207 710/717 0.075 5114 86% 0
127.0.0.1 - - [20/Nov/2012:16:42:40 GMT] "PROPFIND /SOGo/dav/myaccount/Contacts/groups/ HTTP/1.1" 207 508/717 0.012 1364 62% 0
127.0.0.1 - - [20/Nov/2012:16:42:40 GMT] "PROPFIND /SOGo/dav/myaccount/Contacts/groups/ HTTP/1.1" 207 285/181 0.008 - - 0
127.0.0.1 - - [20/Nov/2012:16:42:40 GMT] "PROPFIND /SOGo/dav/myaccount/Contacts/groups/ HTTP/1.1" 207 353/121 0.065 1902 81% 0
127.0.0.1 - - [20/Nov/2012:16:43:10 GMT] "PUT /SOGo/dav/myaccount/Contacts/groups/1c33d9a2-f72a-4b08-8b2b-5b8d91ceb5d8.vcf HTTP/1.1" 401 0/169 0.004 - - 0
127.0.0.1 - - [20/Nov/2012:16:43:11 GMT] "PUT /SOGo/dav/myaccount/Contacts/groups/1c33d9a2-f72a-4b08-8b2b-5b8d91ceb5d8.vcf HTTP/1.1" 404 208/169 0.009 - - 0
127.0.0.1 - - [20/Nov/2012:16:43:11 GMT] "PROPFIND /SOGo/dav/myaccount/Contacts/groups/ HTTP/1.1" 401 0/181 0.003 - - 0
127.0.0.1 - - [20/Nov/2012:16:43:11 GMT] "PROPFIND /SOGo/dav/myaccount/Contacts/groups/ HTTP/1.1" 207 285/181 0.007 - - 0
127.0.0.1 - - [20/Nov/2012:16:43:11 GMT] "PROPFIND /SOGo/dav/myaccount/Contacts/groups/ HTTP/1.1" 207 353/121 0.059 1902 81% 0
127.0.0.1 - - [20/Nov/2012:16:43:11 GMT] "PUT /SOGo/dav/myaccount/Contacts/groups/1c33d9a2-f72a-4b08-8b2b-5b8d91ceb5d8.vcf HTTP/1.1" 404 208/169 0.008 - - 0
127.0.0.1 - - [20/Nov/2012:16:43:11 GMT] "PROPFIND /SOGo/dav/myaccount/Contacts/groups/ HTTP/1.1" 207 285/181 0.008 - - 0
127.0.0.1 - - [20/Nov/2012:16:43:11 GMT] "PROPFIND /SOGo/dav/myaccount/Contacts/groups/ HTTP/1.1" 207 353/121 0.058 1902 81% 0

Contacts.app finds the account, but will only show the server groups and doesn't let me create new entries.

See the "404" error as sogo tries to "PUT" the entry

cxbell

cxbell

2012-11-23 05:56

reporter   ~0004970

Have deleted and re-added the account, no change. Will grab sogo log and see if I've got the same 404 error as above.

perelandra

perelandra

2012-11-30 11:12

reporter   ~0005005

Seems I have found a solution for MY setup (CentOS 5.8, SME Server):

for some reason, Apple contacts.app is not able to discover the default address book from SOGO any more. As soon as I create an additional address book via the SOGO frontend, the contacts.app under OS X discovers the newly created address book properly and works as expected.

Though under iOS, both address books are shown - which doesn't bother me much...

So you might give that a try as a SOGO user. - if the SOGO devs find the reason for this behavior I'd be grateful.

cxbell

cxbell

2012-12-03 14:28

reporter   ~0005021

No joy on that with my system, also running on SME Server - logs as follows

127.0.0.1 - - [03/Dec/2012:19:25:41 GMT] "OPTIONS /SOGo/dav/cxbell/ HTTP/1.1" 401 0/0 0.001 - - 0
127.0.0.1 - - [03/Dec/2012:19:25:41 GMT] "OPTIONS /SOGo/dav/cxbell/ HTTP/1.1" 200 0/0 0.001 - - 0
127.0.0.1 - - [03/Dec/2012:19:25:42 GMT] "PROPFIND /SOGo/dav/cxbell/ HTTP/1.1" 207 510/439 0.003 1541 66% 0
127.0.0.1 - - [03/Dec/2012:19:25:42 GMT] "OPTIONS /SOGo/dav/cxbell/ HTTP/1.1" 200 0/0 0.001 - - 0
127.0.0.1 - - [03/Dec/2012:19:25:42 GMT] "PROPFIND /SOGo/dav/cxbell/Contacts/ HTTP/1.1" 207 755/717 0.005 6557 88% 0
127.0.0.1 - - [03/Dec/2012:19:25:42 GMT] "PROPFIND /SOGo/dav/cxbell/Contacts/groups/ HTTP/1.1" 207 503/717 0.002 1357 62% 0
127.0.0.1 - - [03/Dec/2012:19:25:42 GMT] "PROPFIND /SOGo/dav/cxbell/Contacts/4692-50B8DD80-5-1178B220/ HTTP/1.1" 207 321/181 0.002 - - 0

chrroessner

chrroessner

2012-12-27 20:35

reporter   ~0005085

I can confirm this bug here on Ubuntu 12.04 with SOGo 2.0.3a

The personal addressbook no longer is discovered. Just the directory addressbook.

No changes on client side. Just SOGo upgrade from 2.0.2a to 2.0.3a

2012-12-28 15:18

 

sogo.log-debug.gz (4,288 bytes)
chrroessner

chrroessner

2012-12-28 15:18

reporter   ~0005086

I uploaded my sogo.log with full debug enabled. Hope that helps

chrroessner

chrroessner

2012-12-30 14:37

reporter   ~0005087

for some reason, Apple contacts.app is not able to discover the default address book from SOGO any
more. As soon as I create an additional address book via the SOGO frontend, the contacts.app under OS > X discovers the newly created address book properly and works as expected.

I tested this, too. And I can confirm it.

If creating a new address book, "directory0" - the LDAP address book - disappears and the newly created one is shown. But for me this is not a workaround, as I have this bug on several SOGo servers :(

francis

francis

2013-01-09 11:54

administrator   ~0005103

Fixed. See https://github.com/inverse-inc/sogo/commit/5667bb1b11a7f80dbc4d72deab1f86d8ea30d75e

Notice: with OS X, SOGo only returns the personal addressbook along with the first shared source. However, you can control which of your shared sources is returned since the list is now sorted first.

Issue History

Date Modified Username Field Change
2012-11-12 07:06 perelandra New Issue
2012-11-17 06:06 cxbell Note Added: 0004868
2012-11-19 12:24 francis Note Added: 0004913
2012-11-20 10:48 perelandra Note Added: 0004936
2012-11-20 10:50 perelandra Note Edited: 0004936
2012-11-23 05:56 cxbell Note Added: 0004970
2012-11-30 11:12 perelandra Note Added: 0005005
2012-12-03 14:28 cxbell Note Added: 0005021
2012-12-27 20:35 chrroessner Note Added: 0005085
2012-12-28 15:18 chrroessner File Added: sogo.log-debug.gz
2012-12-28 15:18 chrroessner Note Added: 0005086
2012-12-30 14:37 chrroessner Note Added: 0005087
2013-01-07 16:01 ludovic Target Version => 2.0.4
2013-01-09 11:54 francis Note Added: 0005103
2013-01-09 11:54 francis Status new => resolved
2013-01-09 11:54 francis Fixed in Version => 2.0.4
2013-01-09 11:54 francis Resolution open => fixed
2013-01-09 11:54 francis Assigned To => francis
2013-01-11 12:36 ludovic Relationship added has duplicate 0002017