Dependency Graph

Dependency Graph
related to related to child of child of duplicate of duplicate of

View Issue Details

IDProjectCategoryView StatusLast Update
0002079SOGoWeb Mailpublic2013-01-30 15:49
Reporterjreg2k Assigned Tofrancis  
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.0.2 
Fixed in Version2.0.4b 
Summary0002079: The email tab is empty if a specific email is in INBOX
Description

The e-mail tab is empty but when I try to see what happens with tcpflow, there is a connexion between my sogo server and the mail server. Emails are fetched but are not displayed.

TagsNo tags attached.

Relationships

has duplicate 0002177 resolvedfrancis Folder not showing when mail subject contains unicode SUB character 

Activities

2012-10-29 11:12

 

web-sogo.png (44,261 bytes)   
web-sogo.png (44,261 bytes)   
Christian Mack

Christian Mack

2012-10-30 05:42

developer   ~0004737

Opend a new bug report for the About not visible problem.
Therefore removing it from here.

Also made the title more specific.

JMK

JMK

2012-11-04 13:48

reporter   ~0004770

Please see also issue 0001987 (http://www.sogo.nu/bugs/view.php?id=1987).

I home some example of header leading to the same result.

I tried some test with NGImap4Client/NGImap4ResponseParser but I'm not fluent enough in objective-c to get any result.
Moreover, please disregard the notes associated to the bug .. I was upset against sogo/sope devs at the time :)....

What I not understand is :
1) why sogo/sope does not treat in a sensible way the raised exception (NGImap4ParserException)
2) why there is no display to the user when such error occurs.

2013-01-02 08:13

 

badmail_amazon.eml (23,351 bytes)
bernhard

bernhard

2013-01-02 08:22

reporter   ~0005088

Hi! I have the same issues with multiple emails sent by amazon.

I get two messages in my log like:
<...[UIxEnvelopeAddressFormatter]> unexpected envelope address:...[NGImap4EnvelopeAddress]

All works when accessing the imap folder by i.e. thunderbird, but sogo displays no mail.
Please test it with the attached mail "badmail_amazon.eml"

My system is: Ubuntu 12.04
dovecot 2.0.19
sogo 2.0.3a-1

It would be very nice if someone could take a look over this problem.
best regards,
Bernhard

francis

francis

2013-01-30 15:49

administrator   ~0005287

Fixed. Please try the next nightly build tomorrow.

See https://github.com/inverse-inc/sogo/commit/0408415c61f572ab859c58f44c1d5a028b3fbef7

Issue History

Date Modified Username Field Change
2012-10-29 11:12 jreg2k New Issue
2012-10-29 11:12 jreg2k File Added: web-sogo.png
2012-10-30 05:42 Christian Mack Note Added: 0004737
2012-10-30 05:42 Christian Mack Summary The email tab is empty => The email tab is empty if a specific email is in INBOX
2012-10-30 05:42 Christian Mack Description Updated
2012-10-30 05:47 Christian Mack Issue cloned: 0002083
2012-11-04 13:48 JMK Note Added: 0004770
2013-01-02 08:13 bernhard File Added: badmail_amazon.eml
2013-01-02 08:22 bernhard Note Added: 0005088
2013-01-30 15:46 francis Relationship added has duplicate 0002177
2013-01-30 15:49 francis Note Added: 0005287
2013-01-30 15:49 francis Status new => resolved
2013-01-30 15:49 francis Fixed in Version => 2.0.5
2013-01-30 15:49 francis Resolution open => fixed
2013-01-30 15:49 francis Assigned To => francis